Mapchanger za iGO Primo [Android]

lopard

Pripravnik
12. jun 2013
53
0
6
#42
Pozdravljeni,
znova. Tokrat z drugim problemom. Torej: android, HTC One X+, iGO Primo 9.6.22.297071 in Mapchanger. Do pred kratkim sem imel naložene dosegljive karte iz leta 2012: Topmap in Navteq. Prejšnji teden sem snel nove karte in od takrat je vse narobe. V Content mi samodejno izbriše nekdo končnico (enkrat tm, drugič nq) in potem v zemljevidu ni mogoče nastaviti skina, v zemljevidih nq ni stavb, pa tudi ikone se ne dajo opredmetit. Skratka - sumim, da je problem v mapchangerju ali pa v novih kartah. Mi kdo zna svetovati?

Dušan
 

Janch

GPS guru
Osebje foruma
7. jul 2009
6.334
23
38
v leru
navi-guru.blogspot.com
#43
Narobe si predstavljaš vse skupaj!
Mapchanger ti MORA spremeniti imena mape, da ti lahko Primo sploh potem deluje, torej ne gre za naključje ali napako! Primer:
ko z mapchangerjem določiš, da ti naj Primo zažene NQ zemljevide, ti mapchanger avtomatično spremeni ime izbrane mape in sicer:

map_nq --> map
poi_nq--> poi

ko pa želiš recimo prestavit iz NQ zemljevidov v TT (Tomtom), potem v mapchangerju izbereš TT in v ozadju se zgodi sledeče preimenovanje:

map -->map_nq
poi-->poi_ng

map_tt-->map
poi_tt-->poi

Primo kot program je nedovisna aplikacija in nima nobene neposredne povezave z mapchangerjem, zato Primo hoče v mapi Content\ videti samo klasično ime mape in poi torej MAP in POI. Torej naloga mapchangerja je, da samo preimenuje izbrane mape iz "map_xx" v "map" ter "poi_xx" v "poi" (brez navednic seveda).

SKINI in STAVBE pa itak nimajo nobene povezave z mapchangerjem, tako da ta teorija takoj odpade. Mapchanger ne spreminja nobenih drugih folderjev kot samo MAP in POI po principu, kot sem opisal.
 

Janch

GPS guru
Osebje foruma
7. jul 2009
6.334
23
38
v leru
navi-guru.blogspot.com
#46
Citat:
Uporabnik Slick pravi:
Citat:
Uporabnik Janch pravi:
9.6.22.316005 - Google Play 17 July 2013 - na tej verziji mi spet normalno deluje!
A se lahko ta verzija samo zapelje čez staro ali je treba staro prej odstranit?
Odstraniš iz programov in iz mape iGO pobrišeš vse datoteke in mape, pustiš lahko samo folder CONTENT saj ta se ne spreminja.
 

Slick

Fizikalc
18. sep 2007
1.993
5
38
#47
Odstranil sem program, zamenjal datoteki data.zip in branding.zip ter mapo license, namestil nov APK in pobrisal mapo iGo iz internega spomina, kamor jo (izgleda tako) naredi namestitev sama (ostalo je na kartici). Dela ko šus, tudi Mapchanger sedaj deluje. Hvala.
 

lopard

Pripravnik
12. jun 2013
53
0
6
#48
Hvala za obširen odgovor, ampak - to še vedno ne pojasni mojega problema: na TopMap zemljevidih se recimo vidi moja bajta (izhodišče navigacije), na Navteq karti pa naenkrat nič več (prej se je to videlo. In ko hočem nastaviti skin, mi v nastavitvah ne pokaže Arnija, pač pa le Privzeto... in kot rečeno gumbov ne morem opredmetit: recimo, da mi na gumbu Meni izpiše hitrost, namesto meni.. Skratka - cela zmešnjava. Nekje mora biti razlog za vse to.
Dušan
 

Janch

GPS guru
Osebje foruma
7. jul 2009
6.334
23
38
v leru
navi-guru.blogspot.com
#50
Tvoj problem nima veze z mapchangerjem! Gremo po vrsti:

- Monolitova karta Slovenije (torej ta iz selekcije Topmap) je edina karta Slovenije, ki ima že sama po sebi vrisane 2d tlorise stavb (oranžne lise) in za to ne potrebuje nobenega posebnega dodatka. Tega nima niti NavteQ niti Teleatlas in nikoli nista imela!
- Očitno se ti je Primo postavil na privzete nastavitve, torej ne vidiš menijev in ikon, ki si jih bil vajen in te so verjetno povezane s skinom. Torej je potrebno najprej aktivirati skin
- da izbereš skin, moraš imeti v mapi \iGO\content\skin\ naložen želen skin (to verjetno imaš)
- kako se aktivira skin, če ti ga program ne vidi samodejno, imaš obrazloženo v temi iGO skins. Urediti moraš datoteko sys in info.ini (v obeh moraš ročno vnesti vrednosti za resolucijo)
 

lopard

Pripravnik
12. jun 2013
53
0
6
#51
Prav občudujem tvojo vztrajnost Janch - malo je takih, ki bi bili tako potrpežljivi. Pri meni je doslej delovalo vse normalno. Z resolucijo nisem imel težav, tudi gumbe sem opredmetil... V mapi Building imam 3dc in 3dl datoteke (tudi za Slovenijo) ... Skratka vse je OK. Ko izberem recimo zemljevide TopMap lahko vidim recimo skin Arni 33.. in lahko nastavim gumbe... skratka vse dela normalno. Ko pa vklopim vodenje, pa vse to izgine. Izgine Arni in ostane le privzet skin (ne vem od kod in kakšen), ni opredmetenih gumbov. Še manj stvari je na zemljevidih NavteQ. Tam ni niti zgradbe (v mapi Building so omenjene datoteke).. Skratka Ko nastavljam, je vse OK (razen das e pri NQ ne vidijo stavbe), ko poženem navigacijo pa vse izgine. Resolucija in druge stvari so OK in menim, da niti *.sys niti *.ini datoteki nista krivi, ker se ju nisem dotikal.
 

lopard

Pripravnik
12. jun 2013
53
0
6
#53
Zdravo popotnik,
hvala za nasvet - pobrisal mapo save in res so se ohranile nastavitve skina in vse ostalo. Ostal pa je še vedno osnovni problem: kljub temu da imam v mapi Building datoteke od NavteQ, pa na zemljevidu Slovenije ne vidim stavb (recimo moje domačije), na zemljevidih TopMap pa jih (no Janch mi je razložil, da gre pri TopMap za Monolitove zemljevide, ki imajo to že v sebi. Ne vem pa - zakaj stavb ni na Navteq zemljevidih.
 

popotnik

GPS presidente
Osebje foruma
25. feb 2010
13.227
4
38
Maribor
popotnik-gps.blogspot.com
#54
Probaj naredit še tole:

Izbriši mapo Save in napravo odklopi od PC
Pojdi pod nastavitve/aplikacije in stisni na Primo in stisni gumb vsiljeno zapiranje in nato na počisti podatke
Sedaj zaženi Primo program.

Če še vedno ne bo delovalo pa probaj tole:
Odinštaliraj mapchanger in ga ponovno inštaliraj
Preden ga odinštaliraš stisni gumb vsiljeno zapiranje in počisti podatke.
 

Janch

GPS guru
Osebje foruma
7. jul 2009
6.334
23
38
v leru
navi-guru.blogspot.com
#56
Še vedno imam občutek, da nismo razjasnili pojma "stavbe"


Navteq:



Topmap (Monolit):



v obeh primerih so v mapi Building naložene iste stavbe, ampak kot je razvidno na drugi sliki, ima Monolitova karta poleg prikaza 3d stavb (za to so potrebne datoteke .3dl v mapi Building) še 2d stavbe - oranžni tlorisi, ki pa so že integrirani v sami karti in za to ni potrebnega nobenega dodatka. In te oranžni tlorisi so samo v Topmap selekciji, torej v Monolitovi karti! V NavteQ ali Tomtom zemljevidih teh tlorisov ne moreš videt in to je razlog, da na Navteqovi karti ne moreš videt svoje bajte


Upam da smo se zdaj razumeli
:
 

lopard

Pripravnik
12. jun 2013
53
0
6
#57
Hvala Janch za podrobno razčlenitev razlike med stavbo in tloris neke zgradbe. Se strinjam, da je razlika ogromna. Vseeno pa me zanima nekaj: moj prvi Primo in prve karte sem si namestil in naložil pred dobrim mesecem. Za začetek najprej le karte NavteQ. In na teh kartah sem videl obris moje bajte na naslovu, ki sem ga vpisal ali označil. Torej - videl sem obris svoje hiše. Potem sem zasledil Mapchanger in si dodatno naložil še karte TopMap. Tudi v tej različici je še vse delovalo normalno, dokler si nisem naložil najnovejših kart, ki se bohotijo na pašnikih. In od prejšnjega tedna se mi pojavlja omenjena pomanjkljivosti. Na TopMap vidim obris (tloris) svoje bajte, na NavteQ pa tega ni več. In to je tisto, kar sprašujem. Zakaj naenkrat ne več. Vidim samo senco naselja, ni pa posameznih tlorisov hiš ob cesti in v naselju. Še enkrat: na TopMap da, na NavteQ ne. Prej pa je vse to bilo na obeh. Oprosti, da sem tečen, a res me zanima.
Dušan
 

popotnik

GPS presidente
Osebje foruma
25. feb 2010
13.227
4
38
Maribor
popotnik-gps.blogspot.com
#58
Naloži stare zemljevide nazaj in preveri, če ti bo zopet delalo.
Prenesi karte iz drugega pašnika, morda je s temi kaj narobe
Prenesi nove 3dc in 3dl za 2013.Q1

Edini si s tem problemom, ker vsem ostalim dela kot mora, torej je ali nekaj narobe s tvojo mapo iGO, ali si mogoče nekje onemogočil prikaz stavb pod nastavitvami ali pa so samo karte poškodovane.

Druga kot probavat ti ne preostane ali pa morda izklop in ponoven vklop naprave.
 

popotnik

GPS presidente
Osebje foruma
25. feb 2010
13.227
4
38
Maribor
popotnik-gps.blogspot.com
#60
Jaz imam idejo


Na prejšnji strani je napisal isto težavo z isto verzijo kot si jo imel ti:

Citat:
Maps directory tm moved in nato še Not installed iGO
Po nekem čudnem naključju mu je na koncu začelo delovat ali pa že v osnovi ne tako kot bi moralo in s spremembo kart se mu je pojavil problem.
Sem mu na ZS poslal to kar sedaj uporabljaš ti in ti mapchanger deluje kot mora.
Bomo videli kaj bo ko bo menjal verzijo.